
Simulink®

Getting Started Guide

R2012a



How to Contact MathWorks

www.mathworks.com Web
comp.soft-sys.matlab Newsgroup
www.mathworks.com/contact_TS.html Technical Support

suggest@mathworks.com Product enhancement suggestions
bugs@mathworks.com Bug reports
doc@mathworks.com Documentation error reports
service@mathworks.com Order status, license renewals, passcodes
info@mathworks.com Sales, pricing, and general information

508-647-7000 (Phone)

508-647-7001 (Fax)

The MathWorks, Inc.
3 Apple Hill Drive
Natick, MA 01760-2098
For contact information about worldwide offices, see the MathWorks Web site.

Simulink® Getting Started Guide
© COPYRIGHT 1990–2012 by The MathWorks, Inc.
The software described in this document is furnished under a license agreement. The software may be used
or copied only under the terms of the license agreement. No part of this manual may be photocopied or
reproduced in any form without prior written consent from The MathWorks, Inc.

FEDERAL ACQUISITION: This provision applies to all acquisitions of the Program and Documentation
by, for, or through the federal government of the United States. By accepting delivery of the Program
or Documentation, the government hereby agrees that this software or documentation qualifies as
commercial computer software or commercial computer software documentation as such terms are used
or defined in FAR 12.212, DFARS Part 227.72, and DFARS 252.227-7014. Accordingly, the terms and
conditions of this Agreement and only those rights specified in this Agreement, shall pertain to and govern
the use, modification, reproduction, release, performance, display, and disclosure of the Program and
Documentation by the federal government (or other entity acquiring for or through the federal government)
and shall supersede any conflicting contractual terms or conditions. If this License fails to meet the
government’s needs or is inconsistent in any respect with federal procurement law, the government agrees
to return the Program and Documentation, unused, to The MathWorks, Inc.

Trademarks

MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See
www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand
names may be trademarks or registered trademarks of their respective holders.

Patents

MathWorks products are protected by one or more U.S. patents. Please see
www.mathworks.com/patents for more information.

http://www.mathworks.com/trademarks
http://www.mathworks.com/patents


Revision History
September 2005 Online only New for Version 6.3 (Release 14SP3)
March 2006 Online only Revised for Simulink 6.4 (Release 2006a)
September 2006 Online only Revised for Simulink 6.5 (Release 2006b)
March 2007 First printing Revised for Simulink 6.6 (Release 2007a)
September 2007 Second printing Revised for Simulink 7.0 (Release 2007b)
March 2008 Third printing Revised for Simulink 7.1 (Release 2008a)
October 2008 Fourth printing Revised for Simulink 7.2 (Release 2008b)
March 2009 Fifth printing Revised for Simulink 7.3 (Release 2009a)
September 2009 Online only Revised for Simulink 7.4 (Release 2009b)
March 2010 Online only Revised for Simulink 7.5 (Release 2010a)
September 2010 Online only Revised for Simulink 7.6 (Release 2010b)
April 2011 Online only Revised for Simulink 7.7 (Release 2011a)
September 2011 Sixth printing Revised for Simulink 7.8 (Release 2011b)
March 2012 Seventh printing Revised for Simulink 7.9 (Release 2012a)





Contents

Introduction

1
Product Description . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2
Key Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2

Modeling, Simulation, and Analysis with Simulink . . . 1-3
Tool for Model-Based Design . . . . . . . . . . . . . . . . . . . . . . . . 1-3
Tool for Simulation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-4
Tool for Analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-4
Interaction with MATLAB Environment . . . . . . . . . . . . . . . 1-4

Model-Based Design . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5
What Is Model-Based Design? . . . . . . . . . . . . . . . . . . . . . . . 1-5
Model-Based Design Process . . . . . . . . . . . . . . . . . . . . . . . . 1-6

Documentation and Additional Resources . . . . . . . . . . . 1-9
Simulink Online Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-9
Simulink Demo Models . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-10
Web Site Resources . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-10

Simulink Software Basics

2
Starting Simulink Software . . . . . . . . . . . . . . . . . . . . . . . . 2-2
Opening the Simulink Library Browser . . . . . . . . . . . . . . . 2-2
Creating a New Simulink Model . . . . . . . . . . . . . . . . . . . . . 2-4
Opening an Existing Model . . . . . . . . . . . . . . . . . . . . . . . . . 2-5

Simulink User Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-6
Simulink Library Browser . . . . . . . . . . . . . . . . . . . . . . . . . . 2-6
Simulink Editor Window . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-9

v



Creating a Simulink Model

3
Overview of a Simple Model . . . . . . . . . . . . . . . . . . . . . . . . 3-2

Creating the Simple Model . . . . . . . . . . . . . . . . . . . . . . . . . 3-3
Creating a New Model . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3
Adding Blocks to a Model . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-4
Moving Blocks in the Model . . . . . . . . . . . . . . . . . . . . . . . . . 3-7

Connecting Blocks in the Simple Model . . . . . . . . . . . . . . 3-8
Block Connections in a Model . . . . . . . . . . . . . . . . . . . . . . . . 3-8
Drawing Lines Between Blocks . . . . . . . . . . . . . . . . . . . . . . 3-8
Drawing a Branch Line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-12

Simulating the Simple Model . . . . . . . . . . . . . . . . . . . . . . . 3-14
Setting Simulation Options . . . . . . . . . . . . . . . . . . . . . . . . . 3-14
Running a Simulation and Observing Results . . . . . . . . . . 3-15

Modeling a Dynamic Control System

4
Understanding a Demo Model . . . . . . . . . . . . . . . . . . . . . . 4-2
Overview of the Demo Model . . . . . . . . . . . . . . . . . . . . . . . . 4-2
Opening the Demo Model . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-3
Anatomy of the Demo Model . . . . . . . . . . . . . . . . . . . . . . . . 4-4
Subsystems in the Demo Model . . . . . . . . . . . . . . . . . . . . . . 4-5
Subsystems and Masks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-8
Creating a Subsystem . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-9
Creating a Subsystem Mask . . . . . . . . . . . . . . . . . . . . . . . . . 4-9

Simulating the Demo Model . . . . . . . . . . . . . . . . . . . . . . . . 4-11
Running the Simulation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11
Changing the Thermostat Setting . . . . . . . . . . . . . . . . . . . . 4-12
Changing the Average Outdoor Temperature . . . . . . . . . . . 4-14
Changing the Daily Temperature Variation . . . . . . . . . . . . 4-15

vi Contents



Moving Data Between MATLAB and the Demo
Model . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-17
Importing Data from the MATLAB Workspace . . . . . . . . . 4-17
Exporting Simulation Data to the MATLAB Workspace . . 4-21

Basic Simulation Workflow

5
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-2
Data Import and Logging Workflow . . . . . . . . . . . . . . . . . . 5-2
Example Description . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-2

Import Signal Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-4
Preparing Signal Builder Block . . . . . . . . . . . . . . . . . . . . . . 5-4
Importing Data from Excel Spreadsheets . . . . . . . . . . . . . . 5-6
Displaying Input Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-8

Simulate Model . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-10
Configuring the Model to Log Output Signals . . . . . . . . . . . 5-10
Running the Simulation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-12

Compare Signals . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-14

Create, Save, and Print a Figure . . . . . . . . . . . . . . . . . . . . 5-16
Creating a Figure from a Plot . . . . . . . . . . . . . . . . . . . . . . . 5-16
Saving and Printing a Figure . . . . . . . . . . . . . . . . . . . . . . . . 5-17

Index

vii



viii Contents



1

Introduction

• “Product Description” on page 1-2

• “Modeling, Simulation, and Analysis with Simulink” on page 1-3

• “Model-Based Design” on page 1-5

• “Documentation and Additional Resources” on page 1-9



1 Introduction

Product Description
Simulation and Model-Based Design

Simulink® is an environment for multidomain simulation and Model-Based
Design for dynamic and embedded systems. It provides an interactive
graphical environment and a customizable set of block libraries that let you
design, simulate, implement, and test a variety of time-varying systems,
including communications, controls, signal processing, video processing, and
image processing.

Key Features

• Extensive and expandable libraries of predefined blocks

• Interactive graphical editor for assembling and managing intuitive block
diagrams

• Ability to manage complex designs by segmenting models into hierarchies
of design components

• Model Explorer to navigate, create, configure, and search all signals,
parameters, properties, and generated code associated with your model

• Application programming interfaces (APIs) that let you connect with other
simulation programs and incorporate hand-written code

• MATLAB® Function blocks for bringing MATLAB algorithms into Simulink
and embedded system implementations

• Simulation modes (Normal, Accelerator, and Rapid Accelerator) for running
simulations interpretively or at compiled C-code speeds using fixed- or
variable-step solvers

• Graphical debugger and profiler to examine simulation results and then
diagnose performance and unexpected behavior in your design

• Full access to MATLAB for analyzing and visualizing results, customizing
the modeling environment, and defining signal, parameter, and test data

• Model analysis and diagnostics tools to ensure model consistency and
identify modeling errors
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Modeling, Simulation, and Analysis with Simulink

Modeling, Simulation, and Analysis with Simulink

In this section...

“Tool for Model-Based Design” on page 1-3

“Tool for Simulation” on page 1-4

“Tool for Analysis” on page 1-4

“Interaction with MATLAB Environment” on page 1-4

Tool for Model-Based Design
With Simulink, you can move beyond idealized linear models to explore more
realistic nonlinear models, factoring in friction, air resistance, gear slippage,
hard stops, and the other things that describe real-world phenomena.
Simulink turns your computer into a laboratory for modeling and analyzing
systems that would not be possible or practical otherwise.

Whether you are interested in the behavior of an automotive clutch system,
the flutter of an airplane wing, or the effect of the monetary supply on the
economy, Simulink provides you with the tools to model and simulate almost
any real-world problem. Simulink also provides demos that model a wide
variety of real-world phenomena (see “Simulink Demo Models” on page 1-10).

Simulink provides a graphical user interface (GUI) for building models as
block diagrams, allowing you to draw models as you would with pencil and
paper. Simulink also includes a comprehensive block library of sinks, sources,
linear and nonlinear components, and connectors. If these blocks do not meet
your needs, however, you can also create your own blocks. The interactive
graphical environment simplifies the modeling process, eliminating the need
to formulate differential and difference equations in a language or program.

Models are hierarchical, so you can build models using both top-down
and bottom-up approaches. You can view the system at a high level, then
double-click blocks to see increasing levels of model detail. This approach
provides insight into how a model is organized and how its parts interact.

See “Model-Based Design” on page 1-5 for more information about the
modeling process.
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Tool for Simulation
After you define a model, you can simulate its dynamic behavior using a
choice of mathematical integration methods, either from the Simulink menus
or by entering commands in the MATLAB Command Window. The menus
are convenient for interactive work, while the command line is useful for
running a batch of simulations. For example, if you are doing Monte Carlo
simulations or want to apply a parameter across a range of values, you can
use MATLAB scripts.

Using scopes and other display blocks, you can see the simulation results
while the simulation runs. You can then change parameters and see what
happens for “what if” exploration. The simulation results can be put in the
MATLAB workspace for postprocessing and visualization.

Tool for Analysis
Model analysis tools include linearization and trimming tools, which you can
access from the MATLAB command line, plus the many tools in MATLAB and
its application toolboxes. Because MATLAB and Simulink are integrated,
you can simulate, analyze, and revise your models in either environment
at any point.

Interaction with MATLAB Environment
Simulink software is tightly integrated with the MATLAB environment. It
requires MATLAB to run, depending on it to define and evaluate model
and block parameters. Simulink can also use many MATLAB features. For
example, Simulink can use the MATLAB environment to:

• Define model inputs.

• Store model outputs for analysis and visualization.

• Perform functions within a model, through integrated calls to MATLAB
operators and functions.
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Model-Based Design

In this section...

“What Is Model-Based Design?” on page 1-5

“Model-Based Design Process” on page 1-6

What Is Model-Based Design?
Model-Based Design is a process that enables faster, more cost-effective
development of dynamic systems, including control systems, signal processing,
and communications systems. In Model-Based Design, a system model is
at the center of the development process, from requirements development,
through design, implementation, and testing. The model is an executable
specification that you continually refine throughout the development process.
After model development, simulation shows whether the model works
correctly.

When software and hardware implementation requirements are included,
such as fixed-point and timing behavior, you can automatically generate code
for embedded deployment and create test benches for system verification,
saving time and avoiding the introduction of manually coded errors.

Model-Based Design allows you to improve efficiency by:

• Using a common design environment across project teams

• Linking designs directly to requirements

• Integrating testing with design to continuously identify and correct errors

• Refining algorithms through multidomain simulation

• Automatically generating embedded software code

• Developing and reusing test suites

• Automatically generating documentation

• Reusing designs to deploy systems across multiple processors and hardware
targets
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Model-Based Design Process
There are six steps to modeling any system:

1 Defining the System

2 Identifying System Components

3 Modeling the System with Equations

4 Building the Simulink Block Diagram

5 Running the Simulation

6 Validating the Simulation Results

You perform the first three steps of this process outside of the Simulink
software environment before you begin building your model.

Defining the System
The first step in modeling a dynamic system is to fully define the system. If
you are modeling a large system that can be broken into parts, you should
model each subcomponent on its own. Then, after building each component,
you can integrate them into a complete model of the system.

For example, the demo model used later in this guide models the heating
system of a house. This system is broken down into three main parts:

• Heater subsystem

• Thermostat subsystem

• Thermodynamic model subsystem

The most effective way to build a model of this system is to consider each
of these subsystems independently.
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Model-Based Design

Identifying System Components
The second step in the modeling process is to identify the system components.
Three types of components define a system:

• Parameters — System values that remain constant unless you change
them

• States— Variables in the system that change over time

• Signals — Input and output values that change dynamically during a
simulation

In Simulink, parameters and states are represented by blocks, while signals
are represented by the lines that connect blocks. For each subsystem that you
identified, ask yourself the following questions:

• How many input signals does the subsystem have?

• How many output signals does the subsystem have?

• How many states (variables) does the subsystem have?

• What are the parameters (constants) in the subsystem?

• Are there any intermediate (internal) signals in the subsystem?

Once you have answered these questions, you should have a comprehensive
list of system components, and you are ready to begin modeling the system.

Modeling the System with Equations
The third step in modeling a system is to formulate the mathematical
equations that describe the system. For each subsystem, use the list of system
components that you identified to describe the system mathematically.

Your model may include:

• Algebraic equations

• Logical equations

• Differential equations, for continuous systems

• Difference equations, for discrete systems
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You use these equations to create the block diagram in Simulink.

Building the Simulink Block Diagram
After you have defined the mathematical equations that describe each
subsystem, you can begin building a block diagram of your model in Simulink.

Build the block diagram for each of your subcomponents separately. After
you have modeled each subcomponent, you can then integrate them into a
complete model of the system.

See “Creating the Simple Model” on page 3-3 for more information on building
the block diagram.

Running the Simulation
After you build the Simulink block diagram, you can simulate the model
and analyze the results.

Simulink allows you to interactively define system inputs, simulate the
model, and observe changes in behavior. This allows you to quickly evaluate
your model.

See “Simulating the Simple Model” on page 3-14 for more information on
running a simulation.

Validating the Simulation Results
Finally, you must validate that your model accurately represents the physical
characteristics of the dynamic system.

You can use the linearization and trimming tools available from the MATLAB
command line, plus the many tools in MATLAB and its application toolboxes
to analyze and validate your model.
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Documentation and Additional Resources

In this section...

“Simulink Online Help” on page 1-9

“Simulink Demo Models” on page 1-10

“Web Site Resources” on page 1-10

Simulink Online Help
Simulink software provides comprehensive online help describing features,
blocks, and functions with detailed procedures for common tasks. The help
includes online versions of all Simulink documentation, including:

• Simulink Getting Started Guide (this guide)

• Simulink User’s Guide

• Simulink Graphical User Interface

• Simulink Reference

• Developing S-Functions

• Simulink Release Notes

Access online help from Help menus and context-sensitive block labels.

• From the Simulink Library Browser, select Help > Simulink Help.

• From the Simulink editor window, select Help > Using Simulink.

• Right-click a Simulink block, and then select Help.

• Double-click a Simulink block to open the block parameters dialog box,
right-click a parameter label, and then select What’s This?
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Simulink Demo Models
Simulink software provides a variety of demo models that illustrate key
modeling concepts and Simulink features. You can access these demos from
MATLAB.

1 From the MATLAB task bar, click the Start button.

2 From the Start menu, point to Simulink, and then select Demos.

The Help browser opens and displays a list of Simulink demos.

Web Site Resources
You can access additional Simulink resources on the MathWorks Web site,
including Simulink related books, prerecorded webinars, and technical
support.

To access the Simulink product page, go to

http://www.mathworks.com/products/simulink
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2 Simulink® Software Basics

Starting Simulink Software

In this section...

“Opening the Simulink Library Browser” on page 2-2

“Creating a New Simulink Model” on page 2-4

“Opening an Existing Model” on page 2-5

Opening the Simulink Library Browser
You need MATLAB running before you can open the Simulink Library
Browser.

1 Start MATLAB, and then in the MATLAB Command Window, enter

simulink

The Simulink Library Browser opens.
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Starting Simulink® Software

You can also open the Simulink Library Browser by

• Clicking the Simulink icon on the MATLAB toolbar

• Clicking the Start button on the MATLAB task bar, pointing to Simulink,
and then selecting Library Browser
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Creating a New Simulink Model
Create a new Simulink model from the Simulink Library Browser.

1 From the Simulink Library Browser menu, select File > New > Model.

An empty model opens in the Simulink editor window.

2 Select File > Save.

3 In the Save As dialog box, enter a name for your model, and then click Save.

Simulink saves your model with the file extension .mdl.
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Starting Simulink® Software

Opening an Existing Model
Open an existing Simulink model from the Simulink Library Browser.

1 From the Simulink Library Browser menu, select File > Open.

2 In the Open dialog box, select the model file (.mdl) that you want to open,
and then click Open.

The selected model opens in the Simulink editor window. For example:

Alternatively, you can set your Current Folder in MATLAB to the folder
containing your model, and then in the MATLAB Command Window, enter
the model name.
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Simulink User Interface

In this section...

“Simulink Library Browser” on page 2-6

“Simulink Editor Window” on page 2-9

Simulink Library Browser
The Simulink Library Browser displays the block libraries installed on your
computer. You start to build models by copying blocks from a library into
a Simulink editor window.
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Tips for Using the Library Browser
When using the Library Browser,

• View the blocks in a library — In the left pane, select a library name, or in
the right pane, double-click a library icon.

• Get information on a block — Select the block, and then from the menu,
select Help > Help for the Selected Block. The Help browser opens
with the reference page for the block.

• View block parameters — Right-click a block, and then select Block
parameters.

• Search for a specific block — In the block search field, enter the name of

a block, and then click the find block icon .

Standard Block Libraries
Simulink software includes 16 standard block libraries. The following table
describes each of these libraries.

Block Library Description

Commonly Used
Blocks

Group of the most commonly used blocks, such as
the Constant, In1, Out1, Scope, and Sum blocks.
Each of the blocks in this library are also included in
other libraries.

Continuous Model linear functions using blocks such as the
Derivative and Integrator blocks.

Discontinuities Create outputs that are discontinuous functions of
their inputs using blocks such as the Saturation
block.

Discrete Represent discrete time functions using blocks such
as the Unit Delay block.

Logic and Bit
Operations

Perform logic or bit operations using blocks such as
the Logical Operator and Relational Operator
blocks.
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Block Library Description

Lookup Tables Use lookup tables to determine their outputs from
their inputs using blocks such as the Cosine and
Sine blocks.

Math Operations Perform mathematical and logical functions using
blocks such as the Gain, Product, and Sum blocks.

Model
Verification

Create self-validating models using blocks such as
the Check Input Resolution block.

Model-Wide
Utilities

Provide information about the model using blocks
such as the Model Info block.

Ports &
Subsystems

Create subsystems using blocks such as the In1,
Out1, and Subsystem blocks.

Signal Attributes Modify the attributes of signals using blocks such as
the Data Type Conversion block.

Signal Routing Route signals from one point in a block diagram to
another using blocks such as the Mux and Switch
blocks.

Sinks Display or export output using blocks such as the
Out1 and Scope blocks.

Sources Generate or import system inputs using blocks such
as the Constant, In1, and Sine Wave blocks.

User-Defined
Functions

Define custom functions using blocks such as the
MATLAB Function block.

Additional Math
& Discrete

Additional libraries for mathematical and discrete
function blocks.
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Simulink Editor Window
The Simulink editor window contains a block diagram of your model. You
build models in the editor by dragging blocks from the Simulink Library
Browser window, arranging the blocks logically, connecting the blocks with
signal lines, and then setting the parameters for each block.

The Simulink editor window also allows you to:

• Set configuration parameters for the model, including the start and stop
time, type of solver to use, and data import/export settings.

• Start and stop a simulation of the model.

• Save the model.

• Print the block diagram.
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3 Creating a Simulink® Model

Overview of a Simple Model
You can use Simulink software to model dynamic systems and simulate the
behavior of your models. The basic techniques you use to create a simple
model are the same techniques you will use for more complex models.

To create this simple model, you need four blocks:

• Sine Wave — Generates an input signal for the model.

• Integrator — Processes the input signal.

• Mux— Combines the input signal and processed signal into one signal.

• Scope — Visualizes the signals.

After connecting the blocks, the model integrates a sine wave signal and
displays the result along with the original signal.

You can build this simple model yourself, starting with “Creating a New
Model” on page 3-3.
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Creating the Simple Model

Creating the Simple Model

In this section...

“Creating a New Model” on page 3-3

“Adding Blocks to a Model” on page 3-4

“Moving Blocks in the Model” on page 3-7

Creating a New Model
Before creating a model, you need to start MATLAB and then start Simulink.

1 In the MATLAB Command Window, enter

simulink

The Simulink Library Browser opens.

2 From the Simulink Library Browser menu, select File > New > Model.

A Simulink editor window opens with an empty model.
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3 Creating a Simulink® Model

3 Select File > Save as. The Save As dialog box opens.

4 In the File name box, enter a name for your model, and then click Save.
For example, enter simple_model.

Your model is saved with the file name simple_model.mdl.

Adding Blocks to a Model
To create a model, begin by copying blocks from the Simulink Library Browser
to the Simulink editor window. For a description of the blocks in this example,
see “Overview of a Simple Model” on page 3-2.

1 In the Simulink Library Browser, select the Sources library.

The Simulink Library Browser displays blocks from the Sources library in
the right pane.
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Creating the Simple Model

2 Select the Sine Wave block, and then drag it to the editor window.

A copy of the Sine Wave block appears in your model.

3 Add the following blocks to your model in the same way you added the
Sine Wave block.

Library Block

Sinks Scope

Continuous Integrator

Signal Routing Mux
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3 Creating a Simulink® Model

Your model now has the blocks you need for the simple model.
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Moving Blocks in the Model
Before you connect the blocks in your model, you should arrange them
logically to make the signal connections as straightforward as possible.

1 Move the Scope block after the Mux block output. To move a block in a
model, you can either:

• Click and drag the block.

• Select the block, and then press the arrow keys on the keyboard.

2 Move the Sine Wave and Integrator blocks before the Mux block Inputs.

Your model should look similar to the following figure.

Your next task is to connect the blocks together with signal lines. See
“Connecting Blocks in the Simple Model” on page 3-8.
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Connecting Blocks in the Simple Model

In this section...

“Block Connections in a Model” on page 3-8

“Drawing Lines Between Blocks” on page 3-8

“Drawing a Branch Line” on page 3-12

Block Connections in a Model
After you add blocks to your model, you need to connect them. The connecting
lines represent the signals within a model.

Most blocks have angle brackets on one or both sides. These angle brackets
represent input and output ports:

• The > symbol pointing into a block is an input port.

• The > symbol pointing out of a block is an output port.

��������	� 
��������	�

Drawing Lines Between Blocks
Connect the blocks by drawing lines between output ports and input ports.
For how to add blocks to the model in this example, see “Adding Blocks to
a Model” on page 3-4.

1 Position your mouse pointer over the output port on the right side of the
Sine Wave block.

The pointer changes to a cross hairs (+) shape while over the port.
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2 Click and drag a line from the output port to the top input port of the
Mux block.

While you hold the mouse button down, the connecting line appears as a
dashed line.
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3 Release the mouse button over the output port.

Simulink connects the blocks with an arrow indicating the direction of
signal flow.

4 Drag a line from the output port of the Integrator block to the bottom input
port on the Mux block.

The Integrator block connects to the Mux block with a signal line.

5 Select the Mux block, hold down the Ctrl key, and then select the Scope
block.

A line is drawn between the blocks to connect them. Your model should
now look similar to the following figure.
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Note The Ctrl+click shortcut is useful when you are connecting widely
separated blocks, or when working with complex models.
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Drawing a Branch Line
The simple model is almost complete, but one connection is missing. To finish
the model, you need to connect the Sine Wave block to the Integrator block.

This final connection is different from the other three connections, which all
connect output ports to input ports. Because the output port of the Sine Wave
block is already connected, you must connect this existing line to the input
port of the Integrator block. The new line, called a branch line, carries the
same signal that passes from the Sine Wave block to the Mux block.

1 Position the mouse pointer on the line between the Sine Wave and the
Mux block.

2 Hold down the Ctrl key, and then drag a line to the input port of the
Integrator block input port.

3 From the File menu, click Save. Your model is now complete.
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After you finish building a model, you can simulate the dynamic behavior of
the model. See “Simulating the Simple Model” on page 3-14.
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Simulating the Simple Model

In this section...

“Setting Simulation Options” on page 3-14

“Running a Simulation and Observing Results” on page 3-15

Setting Simulation Options
Before you simulate a model, you have to set simulation options. Specify
options, such as the stop time and solver, using the Configuration Parameters
dialog box. For how to build the model in this example, see “Creating the
Simple Model” on page 3-3.

1 In the Simulink editor window, select Simulation > Configuration
Parameters. The Configuration Parameters dialog box opens to the Solver
pane.

2 In the Stop time field, enter 20, and in theMax step size field, enter 0.2.

3 Click OK.

The software updates the parameter values with your changes and closes
the Configuration Parameters dialog box.
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Running a Simulation and Observing Results
After entering your configuration parameter changes, you are ready to
simulate the simple model and visualize the simulation results.

1 In the Simulink editor window, select Simulation > Start from the menu.

The simulation runs, and then stops when it reaches the stop time specified
in the Configuration Parameters dialog box.

Tip Alternatively, you can control a simulation by clicking the Start

simulation button and Stop simulation button on the editor
window toolbar.

2 Double-click the Scope block.

The Scope window opens and displays the simulation results. The plot
shows a sine wave signal with the resulting cosine wave signal from the
Integrator block.

3 From the toolbar, click the Parameters button , and then the Style tab.
The Scope Parameters dialog box displays the figure editing commands.
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4 Make changes to the appearance of the figure. For example, select white
for the Figure and Axes background color, and change the signal line colors
to blue and green. Click the Apply button to see your changes.

5 Select File > Close.

The Simulink editor window closes with changes to your model and the
configuration parameters.
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Understanding a Demo Model

In this section...

“Overview of the Demo Model” on page 4-2

“Opening the Demo Model” on page 4-3

“Anatomy of the Demo Model” on page 4-4

“Subsystems in the Demo Model” on page 4-5

“Subsystems and Masks” on page 4-8

“Creating a Subsystem” on page 4-9

“Creating a Subsystem Mask” on page 4-9

Overview of the Demo Model
The sldemo_househeat model illustrates how you can use Simulink software
to model a dynamic control system. The model defines a heating system and
the thermodynamics of a house. It includes the outdoor environment, the
thermal characteristics of a house, and the house heating system.

Use this model to explore common Simulink modeling tasks, such as:

• Grouping multiple blocks into a single subsystem block to simplify a block
diagram. See “Subsystems in the Demo Model” on page 4-5.

• Customizing the appearance of blocks using the masking feature. See
“Creating a Subsystem Mask” on page 4-9.

• Simulating a model and observing the results using a Scope block. See
“Running the Simulation” on page 4-11.

• Changing the input parameters of the model to investigate how the system
responds. See “Changing the Thermostat Setting” on page 4-12.

• Importing data from the MATLAB workspace into a model before
simulation. See “Importing Data from the MATLAB Workspace” on page
4-17.

• Exporting simulation data from the model back to the MATLAB workspace.
See “Exporting Simulation Data to the MATLAB Workspace” on page 4-21.
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Opening the Demo Model
The model for this example is called sldemo_househeat. It models the
heating system and thermodynamics of a house.

1 Start MATLAB, and then in the MATLAB Command Window, enter

sldemo_househeat

The Simulink editor opens with the demo model.
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Anatomy of the Demo Model
The sldemo_househeat model defines the dynamics of the outdoor
environment, the thermal characteristics of the house, and the house heating
system. It allows you to simulate how the thermostat setting and outdoor
environment affect the indoor temperature and cumulative heating costs.

The demo model includes many of the same blocks you used to create the
simple model in Chapter 3, “Creating a Simulink Model”. These blocks
include:

• A Scope block (labeled PlotResults) on the far right, displays the
simulation results.

• A Mux block at the bottom right, combines the indoor and outdoor
temperature signals for the Scope.

• A Sine Wave block (labeled Daily Temp Variation) at the bottom left,
provides one of three data sources for the model.

In the model, the thermostat is set to 70 degrees Fahrenheit. Fluctuations in
outdoor temperature are modeled by applying a sine wave with amplitude of
15 degrees to a base temperature of 50 degrees.

The three data inputs (sources) are provided by two Constant blocks (labeled
Set Point and Avg Outdoor Temp), and the Sine Wave block (labeled Daily
Temp Variation). The Scope block labeled PlotResults is the one output
(sink).
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Subsystems in the Demo Model
The sldemo_househeat model uses subsystems to simplify the appearance of
the block diagram, create reusable components, and customize the appearance
of blocks. A subsystem is a hierarchical grouping of blocks encapsulated by a
single Subsystem block.

The demo model uses the following subsystems: Thermostat, Heater, House,
Fahrenheit to Celsius, and Celsius to Fahrenheit.

1 In the MATLAB Command Window, enter

sldemo_househeat

The demo model opens in the Simulink editor window.
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2 Subsystems can be complex and contain many blocks that might otherwise
clutter a diagram. For example, double-click the House subsystem block to
open it.

The subsystem receives heat flow and external temperature as inputs,
which it uses to compute the current room temperature. You could leave
each of these blocks in the main model window, but combining them as a
subsystem helps simplify the block diagram.

4-6



Understanding a Demo Model

3 A subsystem can also be simple and contain only a few blocks. For example,
double-click the Thermostat subsystem block to open it.

This subsystem models the operation of a thermostat, determining when
the heating system is on or off. It contains only one Relay block, but
logically represents the thermostat in the block diagram.
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Subsystems and Masks
The sldemo_househeat model contains two instances of identical subsystems
named Fahrenheit to Celsius. These subsystems convert the inside and
outside temperatures from degrees Fahrenheit to degrees Celsius.

1 Double-click the Fahrenheit to Celsius block.

The custom dialog box for the F2C block opens.

2 To view the underlying blocks in the conversion subsystem, right-click the
F2C subsystem block, and then select Look Under Mask.

The editor displays the blocks behind the mask.
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Creating a Subsystem
Subsystems allow you to group related blocks into one block. They are also
reusable, enabling you to implement an algorithm once and use it multiple
times.

To create a subsystem:

1 In the demo model window, click and drag a select box around the Set Point
and Fahrenheit to Celsius blocks.

2 From the menu, select Edit > Create Subsystem.

The blocks are combined into one subsystem block.

For more information about working with subsystems, see “Creating
Subsystems” in the Simulink User’s Guide.

Creating a Subsystem Mask
You can customize the appearance of a subsystem by using a process known
as masking. Masking a subsystem allows you to specify a unique icon and
dialog box for the Subsystem block. For example, the House and Thermostat
subsystems display custom icons that depict physical objects, while the
conversion subsystems display custom dialog boxes when you double-click
the blocks.

To mask a subsystem:

1 In the demo model window, right-click the new subsystem block, and then
select Create Mask. The Mask Editor dialog box opens.

2 From the Command list, select disp (show text in center of block).
The dialog box displays the syntax for this command below the list.

3 In the Icon Drawing commands field, enter disp('Select
Temperature').
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4 Click OK. The subsystem block displays the text you entered.

For more information about masking subsystems, see “Working with Block
Masks” in the Simulink User’s Guide.
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Simulating the Demo Model

In this section...

“Running the Simulation” on page 4-11

“Changing the Thermostat Setting” on page 4-12

“Changing the Average Outdoor Temperature” on page 4-14

“Changing the Daily Temperature Variation” on page 4-15

Running the Simulation
Simulating the sldemo_househeat model allows you to observe how the
thermostat setting and outdoor environment affect the indoor temperature
and the cumulative heating cost.

1 In the demo model window, double-click the Scope block named
PlotResults. A Scope window opens with two axes labeled HeatCost and
Temperatures.

2 From the menu, select Simulation > Start.

The software simulates the model dynamics, and as the simulation runs,
it displays the results in a Scope window. The cumulative heating cost is
drawn on the HeatCost graph while the indoor and outdoor temperatures
appear on the Temperatures graph.
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Changing the Thermostat Setting
One of the most powerful benefits of modeling a system with Simulink is
the ability to interactively define the system inputs and observe changes in
the behavior of your model. This allows you to quickly evaluate your model
and validate the simulation results.

Change the thermostat setting to 68 degrees Fahrenheit and observe how
the model responds.

1 In the Simulink editor window, double-click the Set Point block. The
Source Block Parameters dialog box opens.

2 In the Constant value field, enter 68.
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3 Click OK. The software applies your changes and closes the dialog box.

4 To rerun the simulation, select Simulation > Start.

The software simulates the model dynamics. Notice that a lower thermostat
setting reduces the cumulative heating cost.
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Changing the Average Outdoor Temperature
Change the average outdoor temperature to 45 degrees Fahrenheit and
observe how the model responds.

1 In the Simulink editor window, double-click the Avg Outdoor Temp block.
The Source Block Parameters dialog box opens.

2 In the Constant value field, enter 45.

3 Click OK. The software applies your changes.

4 To rerun the simulation, select Simulation > Start.

The software simulates the model dynamics. Notice that a colder outdoor
temperature increases the cumulative heating cost.
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Changing the Daily Temperature Variation
Decrease the temperature variation to see how the model responds.

1 In the Simulink editor window, double-click the Daily Temp Variation
block. The Source Block Parameters dialog box opens.

2 In the Amplitude field, enter 5.

3 Click OK. The software applies your changes.

4 To rerun the simulation, select Simulation > Start.

The software simulates the model dynamics. Notice that a more stable
outdoor temperature alters the frequency with which the heater operates.
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Moving Data Between MATLAB and the Demo Model

In this section...

“Importing Data from the MATLAB Workspace” on page 4-17

“Exporting Simulation Data to the MATLAB Workspace” on page 4-21

Importing Data from the MATLAB Workspace
Simulink also allows you to import data from the MATLAB workspace to the
model input ports. This allows you to import actual physical data into your
model. For information about other data import capabilities, see “Importing
and Exporting Simulation Data” in the Simulink User’s Guide.

In this example, you will create a vector of temperature data in MATLAB,
and use that data as an input to the Simulink model.

To import data from the MATLAB workspace:

1 In the MATLAB Command Window, create time and temperature data by
entering the following commands:

x = (0:0.01:4*pi)';
y = 32 + (5*sin(x));
z = linspace(0,48,1257)';

y is a vector of outdoor temperatures that varies from 27 to 37 degrees
Fahrenheit. z is a time vector from 0 to 48. Both vectors contain 1257
values.

2 In the Simulink editor window, select the Avg Outdoor Temp block, and
then press the Delete key to remove it from the model.

3 Delete the following items from the model in the same way:

• Daily Temp Variation block

• Two input signal lines to the Sum1 block

• Sum1 block
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The model should now look similar to the following figure. Notice that the
output signal from the Sum1 block changes to a red, dotted line, indicating
that it is not connected to a block.

4 In the demo model window, select View > Library Browser. The
Simulink Library Browser window opens.

5 In the Simulink Library Browser, select the Sources library.

6 From the Sources library in the right pane, select the In1 block, and then
drag it to the Simulink editor window.

An instance of the In1 block appears in the model window.

7 Connect the dotted line (originally connected to the Sum1 block) to the In1
block.
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8 In the Simulink editor window, select Simulation > Configuration
Parameters.

9 From the menu on the left side of the Configuration Parameters dialog
box, select Data Import/Export.

10 On the Data Import/Export pane, select the Input check box. In the
Input field, enter [z,y].
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11 Click OK. The software applies your changes and closes the dialog box.

12 To rerun the simulation, select Simulation > Start.

The software simulates the model. Notice that the model ran using the
imported data, showing colder outdoor temperatures and higher heat use.
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Exporting Simulation Data to the MATLAB Workspace
Once you have completed a model, you may want to export your simulation
results to the MATLAB workspace for further data analysis or visualization.
For information about additional data export capabilities, see “Exporting
Simulation Data” in the Simulink User’s Guide.

To export the HeatCost data from the model to the MATLAB workspace:

1 In the Simulink Library Browser window, select the Sinks library.

2 From the Sinks library, select the Out1 block, and then drag it to the top
right of the Simulink editor window.

An instance of the Out1 block appears in the model window.

3 Draw a branch line from the HeatCost signal line to the Out1 block. For
more information, see “Drawing a Branch Line” on page 3-12.
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4 Select Simulation > Configuration Parameters.

5 From the menu on the left side of the Configuration Parameters dialog
box, select Data Import/Export.

6 On the Data Import/Export pane, select the Time and Output check
boxes.
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7 Click OK. The software applies your changes and closes the dialog box.

8 To rerun the simulation, select Simulation > Start.

The software simulates the model and saves the time and HeatCost data to
the MATLAB workspace in the variables tout and yout.
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5 Basic Simulation Workflow

Overview

In this section...

“Data Import and Logging Workflow” on page 5-2

“Example Description” on page 5-2

Data Import and Logging Workflow
Simulink provides two features to import data and view simulation results:
the Signal Builder block and the Simulation Data Inspector. Use the Signal
Builder block to import input signals into your model. The Simulation Data
Inspector allows you to view model output signals and compare them.

A typical workflow includes the following steps:

1 Import signal data from a Microsoft® Excel® spreadsheet into a Signal
Builder block. “Import Signal Data” on page 5-4

2 Simulate the model after enabling the logging of output signals during
simulation. “Simulate Model” on page 5-10

3 View and compare the output signals in the Simulation Data Inspector.
“Compare Signals” on page 5-14

4 Create, print, and save a plot from the Simulation Data Inspector. “Create,
Save, and Print a Figure” on page 5-16

Example Description
ex_2counters is a Simulink model that includes a Signal Builder block and
two subsystems, each subsystem is a counter circuit.

• Enabled Subsystem — Increments the counter when the subsystem is
enabled and subsequently retains its output while the subsystem is
disabled. Because the Enable port is configured to reset states when
enabling, the counter returns to zero when the subsystem is re-enabled.

• Triggered Subsystem — Increments the counter for each rising edge of
the control signal.
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Overview

ex_signaldata.xls is a Microsoft Excel file. It contains two sets of input
data on two sheets. The first set of input data is a square wave to test the
model response to an impulse. The second set of input data is a triangular
wave to test the model response to a ramp signal.
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Import Signal Data

In this section...

“Preparing Signal Builder Block” on page 5-4

“Importing Data from Excel Spreadsheets” on page 5-6

“Displaying Input Data” on page 5-8

Preparing Signal Builder Block
The example Excel spreadsheet contains two sets of input data on two
separate sheets. Because the Signal Builder block imports separate sheets
into separate groups, you need to create a second group.

1 From the Simulink Library Browser, select File > Open. Browse to
the folder matlabroot\help\toolbox\simulink\examples, and select
ex_2counters.mdl.

The example model with a Signal Builder block opens in a Simulink editor
window.

2 Double-click the Signal Builder block. A Signal Builder window opens and
displays one data group with a default signal.
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3 From the menu, select Group > Copy. A second tab labeled Group 2
appears.

4 Right-click a group name, and from the submenu, select Rename. Enter a
more meaningful name that describes the input data. For example, enter
Impulse Input and Ramp Input.
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Importing Data from Excel Spreadsheets
Simulink saves data imported from an Excel file using a Signal Builder block
with the model and loads the data into memory when you open the model. If
you have large sets of data, consider using a MAT-file with the Inport block.

1 From the Signal Builder menu, select File > Import from File.
In the Import File dialog box, click the Browse button, find the
folder matlabroot\help\toolbox\simulink\examples, and select
ex_signaldata.xls.

The Data to Import section of the Import File dialog box displays the
Excel file name with a list of sheets in the file.

2 Select the Select All check box.

3 From the Placement for Selected Data list, select Append selected
signals to different groups (in order). Signal Builder converts
the data on each sheet into a group.

4 Click the Confirm Selection button.
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5 Review the Status History pane.

The Status History section includes the following information:

• The data import is successful.

• The Signal Builder block recognizes one signal per sheet.

• The Signal Builder block recognizes the signal name, Amplitude, from
the Excel spreadsheet.

6 Click OK.

5-7



5 Basic Simulation Workflow

Displaying Input Data

1 In the Signal Builder window, select the red default signal labeled Signal 1,
and then press the Delete key. The default signals are removed from both
the Impulse Input and Ramp Input tabs.

2 From the menu, select Axes > Set T Display Limits. In the Set time
range dialog box, enter 2.5 for the maximum time.

3 Select File > Save.

Your signal groups should look like the following. Keep this window open.
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If you don’t see the triangular wave, try clicking Amplitude in the lower
right box.

You can now set up the model to log output signals and simulate. See
“Simulate Model” on page 5-10.
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Simulate Model

In this section...

“Configuring the Model to Log Output Signals” on page 5-10

“Running the Simulation” on page 5-12

Configuring the Model to Log Output Signals
To log and display your output, you must configure the data import and
export parameters of the model.

1 In the model window, select Simulation > Configuration Parameters.
The Configuration Parameters dialog box opens to the Solver pane.

2 In the left pane, select Data Import/Export.

3 Select the following check boxes:

• Time

• Output

• Signal logging

• Record and inspect simulation output

4 From the Format list, select Structure with time.
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5 Click OK.
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Running the Simulation
You can run simulations from the Signal Builder window. Select the input
you want to run with this model or run separate simulations with each of
the defined inputs.

1 In the Signal Builder toolbar, click the Run all button.

Simulink runs the model simulation from 0.0 s to 2.00 s for the Impulse
Input data and then runs again for the Ramp Input amplitude data.
Because you selected Inspect signal logs when simulation is
paused/stopped, the Simulation Data Inspector opens at the end of the
simulation.

2 Select the signals that you want to display.

If you select the input signal and the triggered output signal for Run 1,
two line plots appear in the right pane of the Simulation Data Inspector
window.
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Now, you can inspect the results further. See “Compare Signals” on page 5-14.
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Compare Signals
The Simulation Data Inspector allows you to quickly compare two signals
from the same or different runs.

1 In the Simulation Data Inspector window, click the Compare Signals tab.
By default, five columns are displayed, including Sig 1 and Sig 2.

2 In the Sig 1 column, for Run 1, select the Enable Counter signal. Likewise,
in the Sig 2 column, for Run 2, select the Enable Counter signal.

3 Inspect the signals. In the top pane, the plot contains the two individual
signals. In the bottom pane, a single plot represents the difference of these
two signals.
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To work with your plots as figures, see “Create, Save, and Print a Figure”
on page 5-16.
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Create, Save, and Print a Figure

In this section...

“Creating a Figure from a Plot” on page 5-16

“Saving and Printing a Figure” on page 5-17

Creating a Figure from a Plot
1 In the Simulation Data Inspector window, select the Plot options button
in the upper right of a signal plot. From the submenu, select Plot data
in new figure.

A MATLAB figure window opens with the selected signals.
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Saving and Printing a Figure
To save your figure to your computer:

1 In the Figures window, select File > Save as. A Save as dialog box opens.

2 Navigate to the folder where you want to save your figure.

3 In the File name field, enter the name of your figure.

4 From the Save as type menu, select a file format. If you keep the default,
MATLAB Figure (*.fig), then when you reopen the figure, the model
also opens.

5 Click the Save button.

6 To print the figure, select File > Print.
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